Issue with printing Appointment Lists in the CareCloud platform is currently being investigated
Incident Report for CareCloud
Resolved
The issue with printing Appointment Lists in the platform has been resolved.
Posted May 18, 2018 - 09:27 EDT
Investigating
We are experiencing an issue with printing Appointment Lists in the platform. We apologize for the inconvenience and we continue to investigate the issue.
Posted May 18, 2018 - 09:11 EDT