Issue with uploading and viewing documents (including reports) in the CareCloud platform
Incident Report for CareCloud
Resolved
This incident has been resolved.
Posted May 12, 2018 - 16:09 EDT
Monitoring
We experienced an issue with uploading and viewing documents (including reports) in the CareCloud platform between 2:13pm and 2:36pm ET. We apologize for any inconvenience and we continue to monitor the situation.
Posted May 12, 2018 - 14:44 EDT