The CareCloud Platform is experiencing an issue with the Analytics feature.
Incident Report for CareCloud
Resolved
Our Engineering team has resolved the Issue with Analytics reporting. We apologize for the inconvenience.

-CareCloud Team
Posted Jul 09, 2018 - 18:13 EDT
Investigating
The CareCloud Platform is experiencing an issue with the Analytics feature.

​Our Engineering team is working on this issue as a top priority. Status will be posted when the issue resolved.

​- CareCloud Team
Posted Jul 09, 2018 - 17:46 EDT
This incident affected: Analytics.