Investigating issues with Supervising Physician in Billing Encounters
Incident Report for CareCloud
Resolved
Our team has investigated this issue and have concluded there is no adverse behavior. The supervising physician in Billing Encounters is working as designed. The team will continue to monitor for any anomalies.
Posted Nov 19, 2021 - 13:38 EST
Investigating
We are currently investigating reports of an issue with Supervising Physician in Billing Encounters not persisting in Save, On Hold, and Post Pending Submit queues, in the Billing application, affecting outgoing claims. Our engineering team is working towards a resolution and we will provide updates as they become available.

We appreciate your patience and apologize for this inconvenience.
Posted Nov 19, 2021 - 12:20 EST
This incident affected: Claims.