Investigating
Incident Report for CareCloud
Resolved
All issues have been resolved and all services are back to normal.
Posted Apr 02, 2020 - 19:07 EDT
Update
Our engineering team has identified the issue with our payment processing functionality. The fix will require several more hours to complete. We estimate that the ability to interact with payments (posting new payments, reversing/refunding) should be restored by 9 PM Eastern this evening. We recommend that practices conduct a reconciliation process tomorrow, to ensure that all payments that were posted today were properly registered. Again we apologize for the inconvenience.
Posted Apr 02, 2020 - 16:27 EDT
Update
We are currently experiencing an outage with our payment processing functionality. Our engineers are actively working on restoring these services.

Please note that any transaction related to payments, i.e. posting, reversing or refunding a payment or posting a remittance will return an error message. Nonetheless, the transactions ARE being recorded, but have been queued for processing once the current outage has been resolved. We recommend refraining from posting any of these transactions until this issue is resolved. We will update the Status page once the payment processing functionality has been fully restored.
Posted Apr 02, 2020 - 12:37 EDT
Update
Our engineers are reporting that systems are coming back online and users should be able to access CareCloud. Though we continue to validate the incident, slowness might be occurring as we continue to bring all services online.
Posted Apr 02, 2020 - 11:10 EDT
Update
Our engineers are making progress to remediate the issue, we will continue to provide additional updates as they become available.
Posted Apr 02, 2020 - 10:31 EDT
Update
Our engineers are continuing to remediate the issue, we will continue to provide additional updates as they become available.
Posted Apr 02, 2020 - 10:00 EDT
Identified
Our team has identified the cause of this issue and is actively taking steps to remediate impact. We will continue to provide additional updates as they become available.
Posted Apr 02, 2020 - 09:13 EDT
Investigating
Our engineering team is currently investigating an issue with CareCloud not loading. Our engineering team is currently investigating and we'll provide an update shortly.
Posted Apr 02, 2020 - 07:59 EDT
Monitoring
Our teams have validated that all affected services are recovered at this time. We are continuing to monitor for any additional impact.
Posted Apr 02, 2020 - 02:13 EDT
Investigating
We're investigating reports of CareCloud website not loading. Our engineering team is currently investigating and will provide an update once additional information is available.
Posted Apr 02, 2020 - 00:15 EDT
This incident affected: Community and Payment Transactions.