Investigating
Incident Report for CareCloud
Resolved
This incident has been resolved.
Posted Sep 10, 2021 - 00:45 EDT
Investigating
We have received reports of users receiving errors when working in the application. Our engineering team is working towards a resolution and we will provide updates as they become available.
Posted Sep 09, 2021 - 19:05 EDT
This incident affected: Community.