Investigating issue with Draft Patient Statements
Incident Report for CareCloud
Resolved
This issue was resolve in the October 7th Release.
Posted Nov 19, 2021 - 13:27 EST
Investigating
**Investigating issue with Draft Patient Statements**

We are investigating the following issue: Preview of patient statements are missing detailed information. This does not affect assembled statements to the Outbox folder are not affected, the issue is with Preview only.

Our team is currently working it identify a fix for this issue. We will provide an update as soon as it's available.
Posted Oct 08, 2021 - 16:32 EDT
This incident affected: Patient Statements.