Issue with CareCloud
Incident Report for CareCloud
Resolved
Some users might have experienced an issue with loading CareCloud between 2:30 PM - 2:43 PM EDT. Our engineers have mitigated the issue and all systems are operating at normal levels.
Posted Oct 15, 2019 - 15:45 EDT
This incident affected: Community.