MIPS Outage
Incident Report for CareCloud
Resolved
At this time our MIPS dashboard issue has been resolved.
Posted Oct 20, 2020 - 14:19 EDT
Investigating
Our third-party provider for MIPS is currently experiencing an outage. We're working with them and will provide additional updates as they become available.
Posted Oct 20, 2020 - 13:02 EDT
This incident affected: Charts and Interfaces.