Issues with receiving/making calls with client support center
Incident Report for CareCloud
Resolved
Our phone systems are now fully operational and everything has recovered.
Posted Nov 05, 2018 - 12:32 EST
Update
We are continuing to work with our telecom service provider.
Posted Nov 05, 2018 - 11:46 EST
Investigating
Our telecom provider has identified an issue and we're currently working closely with them on fixing this.

We'll provide more updates shortly.
Posted Nov 05, 2018 - 11:37 EST