Investigating
Incident Report for CareCloud
Resolved
This incident has been resolved.
Posted Apr 19, 2019 - 17:16 EDT
Monitoring
The issue has been identified and a fix has been implemented.
Posted Apr 19, 2019 - 17:00 EDT
Investigating
We're investigating reports of the analytics app not loading reports. We will provide more information shortly.
Posted Apr 19, 2019 - 16:45 EDT
This incident affected: Analytics.