Investigating Pharmacy Search
Incident Report for CareCloud
Resolved
This incident has been resolved.
Posted Feb 14, 2021 - 00:01 EST
Investigating
We are currently investigating an issue related to pharmacies searches, when the location is changed from 'Home' to an alternate value. We’re working with our third party vendor that provides our pharmacy geolocation data. We will provide an update as more information is available.
Posted Feb 13, 2021 - 18:56 EST
This incident affected: Community.