Investigating EPCS (controlled substance prescribing) related issues
Incident Report for CareCloud
Resolved
This incident is resolved. If you experience any additional issues please reach out to your Client Support Team.
Posted Sep 11, 2021 - 21:01 EDT
Investigating
We are currently investigating reports of EPCS related issues, impacting the ability to e-prescribe controlled substances. Our engineering team is working towards a resolution and we will provide updates as they become available. During this time, users may experience intermittent connectivity to CareCloud.

We appreciate your patience and apologize for this inconvenience.
Posted Sep 11, 2021 - 16:21 EDT
This incident affected: Charts.