Issue with viewing documents (including reports) in the CareCloud platform.
Incident Report for CareCloud
Resolved
This incident has been resolved.
Posted Nov 13, 2018 - 16:17 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2018 - 15:42 EST
Update
We are continuing to investigate an issue where document viewing is intermittently failing for some clients. We will update here as soon as we have identified root cause.
Posted Nov 13, 2018 - 14:00 EST
Investigating
We are experiencing an issue with viewing documents (including reports) in the CareCloud platform. We apologize for any inconvenience and we continue to work to resolve the issue as soon as possible.
Posted Nov 13, 2018 - 12:14 EST
This incident affected: Analytics and Patient Statements.