Issues with TalkDesk (Call management system)

Incident Report for CareCloud

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:17 EDT

Identified

Due to the ongoing AWS (Amazon Web Services) outage, we are currently experiencing issues with our Call Management System (TalkDesk). As a result, incoming calls to the Support Center may not be connecting or answered at this time.

We will provide updates as soon as more information becomes available.
Posted Oct 20, 2025 - 12:37 EDT
This incident affected: Client Support - Incoming External Phone Calls.