Remittance Issues

Incident Report for CareCloud

Monitoring

Yesterday the team verified that the nightly process completed successfully, and remittance postings should now be reflected as expected. A fix was also implemented for the issue preventing users from creating batches within the Remittance application, and this functionality should now be working properly.

We will continue to monitor the system over the next few days to ensure ongoing stability.
Posted Nov 27, 2025 - 17:17 EST

Investigating

The Production team has identified an issue with last night’s nightly process, which has caused a significant delay in the Remittance batch posting. We have also received reports of users being unable to create a batch within the Remittance application, and this is currently under investigation.

We will provide additional updates as soon as more information becomes available.
Posted Nov 26, 2025 - 10:19 EST
This incident affects: Remittance.