Issue: Claim Assembly Failures

Incident Report for CareCloud

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 11:42 EDT

Update

Our team continues to investigate and address the issue. In the meantime, please continue attempting to assemble claims, as they should successfully assemble after a few attempts.

We appreciate your patience and will provide further updates as they become available.
Posted Mar 26, 2025 - 13:35 EDT

Investigating

We have received reports of users experiencing failures when attempting to assemble claims. Some users have noted that after multiple attempts, the claims eventually assemble.

Our engineering team is actively investigating this issue and will provide updates as soon as possible. We appreciate your patience as we work to resolve this.
Posted Mar 26, 2025 - 12:18 EDT
This incident affected: Claims.