"Something Went Wrong" Error in Analytics Application

Incident Report for CareCloud

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 09:10 EDT

Monitoring

The product team has implemented a fix, and users should now be able to run reports in the Analytics application. The team is actively monitoring the reporting aspect of the system to ensure no further issues.

This outage was caused by an outage at our snowflake vendor and backlog of queues were created which overwhelmed the system. Our reporting component (Analytics) was being affected by this outage.

To view Snowflake status, access the following website below:
https://status.snowflake.com

Thank you for your patience during this time.
Posted Mar 19, 2025 - 19:19 EDT

Update

Our investigation has determined that the issue appears to be related to a third-party vendor. We are working closely with them to resolve the problem as quickly as possible. Our team continues to monitor the situation and will provide further updates as we receive more information.
Posted Mar 19, 2025 - 12:08 EDT

Investigating

We are currently investigating reports of users encountering a "Something Went Wrong" error when attempting to access the Analytics application. Our development team is actively working to identify the cause and implement a solution.

We apologize for the inconvenience and will provide updates as soon as possible.
Posted Mar 19, 2025 - 12:05 EDT
This incident affected: Analytics.