The Engineering team has implemented a fix for the eligibility verification issue affecting all payers except Medicare. Eligibility checks for other payers should now function as expected without errors.
The team has identified the root cause of the issue impacting Medicare eligibility verification and is actively working to restore full functionality. We will provide further updates as more information becomes available. Thank you for your patience.
Posted Mar 20, 2026 - 16:31 EDT
Update
We are currently receiving reports of eligibility verification issues affecting all payers. The team is actively investigating and working to identify the root cause. We will provide updates as more information becomes available. Thank you for your patience.
Posted Mar 20, 2026 - 15:37 EDT
Investigating
We are currently investigating an issue where users are encountering errors when attempting to check Medicare eligibility. The Engineering team is actively working to resolve the issue and will provide updates as more information becomes available. Thank you for your patience.