Issues with Printing/Generating documents within CareCloud

Incident Report for CareCloud

Monitoring

The Production team has implemented a fix for the issue impacting the printing and generation of documents within CareCloud. Users should now be able to successfully print and generate Superbills, Statements, Analytic reports, and other documents as expected. The team will continue to closely monitor the system to ensure ongoing stability. Thank you for your patience and understanding.
Posted Sep 11, 2026 - 09:07 EDT

Investigating

We are currently receiving reports of users being unable to print or generate various types of documents within CareCloud, including Superbills, Statements, and Analytic reports. The Production team is actively investigating the issue and will provide updates as more information becomes available. Thank you for your patience and understanding.
Posted Sep 11, 2026 - 08:54 EDT
This incident affects: Analytics and Documents.