Status Update
Incident Report for CareCloud
Resolved
This incident has been resolved.
Posted Sep 18, 2023 - 09:53 EDT
Monitoring
Corrections for the Charge Posting with Referral Provider, Clinical Plan, and Quick Text have been fully deployed.
Please note that it will be necessary for you to restart the CareCloud application to apply these changes.
If you continue to experience any issues with the above items, please contact our support desk for further assistance.
Posted Sep 15, 2023 - 17:55 EDT
Update
Charge Posting with Referring Provider Issue - The solution is currently in the final stages and should be moving to QA shortly. Once it passes QA, we will provide an update on deployment timelines.
The team is also finalizing the solution for the other two reported issues regarding Quick Text and Clinical Plan and will likely deploy the correction at the same time.
Posted Sep 15, 2023 - 15:56 EDT
Investigating
We are receiving reports of issues with posting charges with an attached referring provider. Our team is currently investigating and will provide updates shortly.
Posted Sep 15, 2023 - 10:00 EDT
This incident affected: Community.