Issues with errors and slowness in CareCloud App

Incident Report for CareCloud

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 13:34 EST

Monitoring

The Product team has implemented a fix, and system performance is normalizing. Users should no longer experience slowness or error messages. The team will continue to closely monitor all areas to ensure ongoing stability. Thank you for your patience and understanding.
Posted Mar 03, 2026 - 11:59 EST

Investigating

We are currently receiving reports of system slowness and error messages. The Product team is actively investigating the issue to determine the root cause and restore optimal performance as quickly as possible. We will provide updates as more information becomes available. Thank you for your patience and understanding.
Posted Mar 03, 2026 - 11:49 EST
This incident affected: Community and Charts.