Issues within the CareCloud Application

Incident Report for CareCloud

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 17:01 EDT

Monitoring

Our Engineering team has implemented changes aimed at improving overall system stability. To ensure optimal performance, we recommend the following steps:

-Clear the application cache via the system menu
-Close the application and restart it
-Ensure you are toggled to the latest version upon login

If performance does not improve, we recommend performing a full restart of your computer and then relaunching the application.

We are also aware of a “Security Error” message that some users may encounter during login. This message can be bypassed by selecting “OK” and is not related to any actual security concern. It is associated with ongoing system updates.

We will continue to monitor system performance and provide additional updates as needed.
Posted Apr 13, 2026 - 12:58 EDT

Identified

The issue has been identified and is currently affecting multiple applications within the system, including login, e-prescription, and general functionality (e.g., “Something went wrong” errors and loading issues). Our Engineering team is actively working toward a resolution.

We will continue to provide updates as more information becomes available.
Posted Apr 13, 2026 - 10:13 EDT

Investigating

We have received reports of users experiencing login issues when accessing the CareCloud application. Our Engineering team is actively investigating and working toward a resolution.

We will provide additional updates as soon as more information becomes available.
Posted Apr 13, 2026 - 08:51 EDT
This incident affected: Community.