ALERT - Issues reported with Eligibility Verification
Incident Report for CareCloud
Resolved
This incident has been resolved.
Posted Oct 04, 2023 - 11:10 EDT
Investigating
We are receiving reports of users experiencing issues with Medicare Eligibility verification.
Our team is actively investigating the issue and will update you with more details as we have them
Posted Sep 27, 2023 - 15:09 EDT
This incident affected: Eligibility.