Unable to view documents
Incident Report for CareCloud
Resolved
This incident has been resolved.
Posted May 22, 2020 - 13:23 EDT
Monitoring
Our teams have validated that all affected services are recovered at this time. We are continuing to monitor for any additional impact.
Posted May 22, 2020 - 11:40 EDT
Investigating
We're investigating reports of an issue with documents not loading properly. We have engaged our engineers and will provide an update when we get additional information.
Posted May 22, 2020 - 10:46 EDT
This incident affected: Documents.