Patient Self-Reported Information From Breeze

Incident Report for CareCloud

Resolved

The issue has been resolved
Posted 1 month ago. Jan 30, 2025 - 09:12 EST

Investigating

We are investigating an issue where patient-submitted information from Breeze is not displaying in the EHR for provider review. Our team is actively working to identify the root cause and will provide updates as we make progress.
Posted 1 month ago. Jan 30, 2025 - 07:32 EST
This incident affected: Breeze.