Claims Submission Delay

Incident Report for CareCloud

Resolved

All claims impacted by last night’s technical issue have now been successfully submitted. We apologize for the inconvenience this may have caused and appreciate your patience while we worked to resolve the matter.
Posted Sep 04, 2025 - 09:25 EDT

Identified

Team has figured out the issue -
Recommending we can generate claims. But we have to wait for 8 PM.
Posted Sep 03, 2025 - 10:58 EDT

Investigating

We experienced a technical issue last night that prevented our scheduled jobs from running, which caused claims not to be submitted as expected. We sincerely apologize for this disruption.
The queued claims are being prioritized and will be submitted today. Our team is actively monitoring the process to ensure timely completion and to prevent recurrence.
Thank you for your patience and understanding.
Posted Sep 03, 2025 - 10:00 EDT
This incident affected: Claims.