Resolved: Errors in the System

Incident Report for CareCloud

Resolved

The system is now running optimally. If you continue to experience any issues, please contact our Support Team for further assistance at (866) 931-3832.
Thank you for your continued patience.
Posted Oct 16, 2025 - 18:30 EDT

Monitoring

The system was experiencing issues with errors and login access earlier today. A fix has been implemented, and the system should now be normalizing and continuing to improve. Our team is actively monitoring performance to ensure full stability.
Posted Oct 16, 2025 - 12:42 EDT
This incident affected: Community.