Service Interruption Impacting Eligibility, Claims, and Remittances (Commercial Payers)

Incident Report for CareCloud

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 09:00 EDT

Identified

We are currently experiencing a service interruption impacting eligibility checks, 837 claim submission and 835 remittances for commercial payors, which is related to a connectivity issue with one of our trading partners.

Our team is actively working with the trading partner to restore full functionality as quickly as possible. We will continue to monitor the situation closely and provide updates as more information becomes available.

We appreciate your patience and understanding while we work to resolve this.
If you have any immediate concerns or questions, please don’t hesitate to reach out.
Posted Mar 30, 2026 - 20:33 EDT
This incident affected: Eligibility, Claims, and Remittance.