The remittance posting issue should now be resolved. A fix has been implemented, and the system has successfully loaded all pending remittances. We will continue to monitor the services throughout the evening to ensure the issue remains fully resolved.
Posted Nov 14, 2025 - 09:03 EST
Identified
Our teams continue to work on the Remittance Posting issue. A potential fix was deployed yesterday; however, it did not fully resolve the problem due to an underlying AWS NFS (Network File System) issue.
The EDI, DevOps, and Central Engineering teams are actively collaborating with AWS to address the NFS issue. We will provide further updates as soon as additional information becomes available.
Posted Nov 13, 2025 - 10:01 EST
Investigating
Our Production team has identified an issue with the Remittance Posting process, where files are not being loaded into the CareCloud application as expected. The EDI team is actively working with our DevOps and Central Engineering teams to resolve the issue. We will provide an update as soon as more information becomes available.