CareCloud Message on Recent Platform Stability
Incident Report for CareCloud
Resolved
This incident has been resolved.
Posted Nov 19, 2021 - 13:39 EST
Identified
As you know, our system has been experiencing intermittent issues that may have made it difficult for you to access our platform. We want to take this opportunity to assure you that we are aware of the issue and we are working hard to improve your experience as quickly as possible.

Our Engineering and Development Operations teams have worked tirelessly to get to the bottom of the issue and we’ve been successful at reducing the frequency of errors by implementing and reviewing additional logging tools. Although the issues manifested themselves similarly (i.e. with the platform ‘crashing’ or displaying ‘503’ errors) they stemmed from more than one root cause.

During the first week of March, we were able to identify and fix some of the underlying causes, and have since seen drastically fewer errors. Nonetheless, some errors continue to persist.

In furthering our commitment to maintain platform stability, we are dedicating the next several months to platform efficiency, uptime and speed. Some of our efforts will include the collaboration of our Engineering, Product and Development Operations teams, and we are also building a dedicated engineering team solely focused on system stability engagements.

With our concentrated force of resources dedicated to making our system run more efficiently, we are confident that your experience will significantly improve over the coming days, and weeks.

We'll continue to update this message as we progress through this process.
Posted Mar 19, 2021 - 14:24 EDT