Intermittent issues with outbound E-fax

Incident Report for CareCloud

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:17 EDT

Monitoring

Our e-fax vendor, SFAX, has implemented changes to their sending ANI to help mitigate any previous delivery blocks to potential recipients. These updates are expected to improve fax transmission success rates across all users.
Posted Oct 17, 2025 - 15:06 EDT

Investigating

Our e-fax partner, SFAX, has notified us that they are experiencing some outbound call failures causing outbound faxes to incorrectly fail with the error 'no pickup' - they have identified the issue and their technical teams are currently working as quickly as they can to resolve this. We will continue to monitor the situation, and provide status updates when the issue has been reported as resolved.
Posted Oct 15, 2025 - 16:09 EDT
This incident affected: Fax Service.