Issue with Medicare Eligibility

Incident Report for CareCloud

Investigating

We are currently encountering issues with validating patient eligibility for Medicare in CareCloud Health. The DevOps team, along with the EDI team, is actively investigating the matter.
Please note that eligibility verification for all other insurances is functioning normally.
Posted Oct 17, 2025 - 15:08 EDT
This incident affects: Eligibility.