We are pleased to inform you that the issue has been resolved. All CareCloud Payment apps have now been successfully pushed to the affected Clover devices.
If you continue to experience any issues or have further questions, please contact our support team for assistance.
Thank you for your patience throughout this process.
Posted Sep 26, 2024 - 08:39 EDT
Monitoring
Fiserv has now pushed the CareCloud Payment app back to all affected Clover devices. We are currently monitoring the process. If the app has not yet appeared on your device, please check for any notifications on the device itself indicating the app is being reinstalled.
If no notification or app has been received, the CareCloud Payment app should be automatically installed tonight as part of Fiserv's nightly updates.
Thank you for your continued patience as we ensure all devices are updated properly.
Posted Sep 25, 2024 - 11:18 EDT
Investigating
We have identified an issue where the CareCloud Payment app has been removed from Clover devices. This appears to be an issue on Fiserv's end, and we are currently engaging their management for further details and a resolution.
We understand the critical impact this has on your daily workflow, and we are working closely with Fiserv to resolve this as quickly as possible.
Thank you for your patience and understanding during this time. We will provide updates as more information becomes available.