The Engineering team has implemented a fix and verified that last night’s overnight processes ran successfully. Remittance and claims processing have also been confirmed as functioning correctly. The team will continue to monitor the system to ensure ongoing stability. Thank you for your patience.
Posted Apr 03, 2026 - 08:45 EDT
Identified
The Engineering team has identified an issue with last night’s overnight process not running, which has impacted several components, including remittance and claims processing. The team is actively working toward a resolution and will provide updates as more information becomes available. Thank you for your patience.
Posted Apr 02, 2026 - 09:28 EDT
Update
We are continuing to monitor for any further issues.
Posted Apr 01, 2026 - 12:25 EDT
Monitoring
The Engineering team has implemented a fix, and claim assembly and remittance posting are now functioning correctly. The team is continuing to review and will provide additional details regarding any remaining batches that did not process during last night’s overnight run. Thank you for your patience.
Posted Apr 01, 2026 - 12:17 EDT
Identified
Our engineering teams have identified an issue with multiple RCM processes including claims assembly and remittance batch posting that is currently being investigated. We will provide updates as more information becomes available. Potential impacts include: Claims assembly failures and remittance batch posting failures from the outbox in the overnight processes. We appreciate your patience.