Issue with Integrated Credit Card Payments Appearing to Fail

Incident Report for CareCloud

Monitoring

The Product Team has implemented a fix for the credit card payment transaction issue, and the solution is currently being monitored for stability.

If you continue to experience any issues, please reach out to our Support Team at 866-931-3832 for assistance.

Thank you for your patience while we worked to resolve this matter.
Posted Sep 12, 2025 - 12:34 EDT

Identified

We have identified an issue affecting integrated credit card payment transactions processed either through Patient Financials at the clinic or via the Breeze portal. In certain cases, transactions are being debited multiple times from patient accounts.

This occurs when a payment initially fails with the error message:
“Unable to Post Payment at this time. Please try again later.”

Although the payment appears to fail, it is actually queued to process in the background. If additional attempts are made, this can result in duplicate charges to the patient’s bank account, creating overpayments.

Action Required:
If you encounter this error message, please do not reattempt the payment. Instead, contact our Support Team at 866-931-3832 to report the issue.

Our team is actively working to resolve this matter and will provide further updates as they become available.
Posted Sep 10, 2025 - 13:21 EDT
This incident affects: Payment Transactions.