TalkDesk Phone Service Disruption

Incident Report for CareCloud

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 13:26 EDT

Monitoring

Inbound calls are now coming through successfully; however, there is still service degradation reported on TalkDesk’s side, as noted on their status page.

We are actively monitoring the situation and will provide further updates as they become available.

Thank you for your continued patience.
Posted Jun 10, 2025 - 12:26 EDT

Identified

Our phone service provider, TalkDesk, is currently experiencing technical issues. As a result, inbound calls to our Support Department are temporarily unavailable.

We recommend monitoring TalkDesk’s status page for real-time updates: https://status.talkdesk.com

We apologize for the inconvenience and appreciate your patience as the provider works toward a resolution.
Posted Jun 10, 2025 - 12:15 EDT
This incident affected: Client Support - Incoming External Phone Calls.