CareCloud Incident
Incident Report for CareCloud
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 11:13 EDT
Monitoring
A fix has been implemented and we're monitoring the results.
Posted Mar 22, 2024 - 10:46 EDT
Investigating
We are currently investigating an issue with the CareCloud app. Our engineering team is currently investigating and will provide updates once we determine the root cause.
Posted Mar 22, 2024 - 10:22 EDT
This incident affected: Community.