System Maintenance 4/20/2026 11:00 p.m. EST

Incident Report for CareCloud

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 10:44 EDT

Monitoring

Our Engineering team will be performing a maintenance update tonight (4/20/2026) at 11:00 PM EST. This maintenance is expected to last approximately 10 minutes.
During this time, users may experience intermittent issues with logging in or general system responsiveness

Immediately following the upgrade, our team will conduct comprehensive platform-wide testing to ensure all systems are operating as expected. This validation process will continue into the early morning hours to confirm system stability and performance. If any issues are identified, updates will be promptly posted to this status page.

We appreciate your understanding as we work to improve system performance and stability.
Posted Apr 20, 2026 - 16:19 EDT
This incident affected: Community.