Yesterday evening, our third-party fax vendor reported that they identified and corrected the cause of the performance issues experienced earlier in the day. All faxing functionality should now be fully restored.
Their team is continuing to monitor the queues to ensure stable performance.
Posted Dec 10, 2025 - 08:11 EST
Identified
Our third-party vendor, SFax, has provided an update indicating that additional issues have been identified with the faxing service. The faxing service is currently experiencing degraded performance. Their engineering team is actively investigating and working toward a resolution.
We will provide further updates as soon as additional information becomes available.
Our third-party fax vendor has identified the root cause of the incident and implemented a fix. They have reported that fax functionality has stabilized, and backlogged faxes are processing. Performance continues to be monitored to ensure ongoing stability.
Posted Dec 08, 2025 - 20:22 EST
Investigating
Our third-party digital fax vendor, SFAX, has reported an outage affecting both incoming and outgoing fax services. We are actively monitoring the situation and will provide additional updates as they become available.