Issues with Logging in and Errors in the system

Incident Report for CareCloud

Resolved

The issue has been successfully resolved, and the system is now operating optimally. Our team will continue to monitor performance to ensure continued stability.

If you experience any issues, please contact our Support Center at (866) 931-3832 for assistance.

Thank you for your patience and understanding during this time.
Posted Mar 20, 2025 - 09:11 EDT

Update

The system is now operating optimally, and our team continues to actively monitor performance to ensure stability.

Snowflake services, which previously impacted the reporting component of our software, are now fully operational. As a result, reporting functionality has been restored.

For the latest updates on Snowflake’s status, please visit: https://status.snowflake.com.

Thank you for your patience and understanding throughout this process.
Posted Mar 19, 2025 - 19:30 EDT

Monitoring

The product team has implemented a fix, and users should now be able to log in to the CareCloud application. The team is actively monitoring system performance to ensure stability and will provide a further update once there is full confidence that the system is back to normal.

Additionally, Snowflake services are currently down, which is impacting the reporting component of our software. As Snowflake is a critical part of our reporting suite, this may continue to affect reporting functionality.

For the latest updates on Snowflake’s status, please visit: https://status.snowflake.com.

We appreciate your patience and understanding during this time.
Posted Mar 19, 2025 - 16:09 EDT

Identified

Our product team is still actively working on resolving the ongoing login issues and system errors. Progress is being made, and we remain committed to restoring normal system functionality as quickly as possible.

We appreciate your continued patience and will provide further updates as soon as possible.
Posted Mar 19, 2025 - 15:29 EDT

Update

Our team is continuing to work diligently to resolve the ongoing login issues and system errors. We apologize for the delay and any inconvenience this may be causing. Restoring normal system functionality remains our top priority, and we are committed to resolving this as quickly as possible.

We will provide further updates as soon as possible. Thank you for your patience and understanding.
Posted Mar 19, 2025 - 14:20 EDT

Investigating

We are currently experiencing issues with logging in and encountering errors within the system. Our team is actively investigating the cause and working to resolve the issue as quickly as possible.

We apologize for the inconvenience and appreciate your patience. Further updates will be provided as they become available.
Posted Mar 19, 2025 - 13:00 EDT
This incident affected: Analytics, Community, Eligibility, Charts, Chat, Claims, Collections, Patient Search, Remittance, Documents, and Payment Transactions.